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Plone 4 Basics: Creating Events & News Items
Document Overview
All University of Louisville departments that have managed their own website in the
past (using Plone 3) will be required to rebuild their site in the Plone 4 environment.
The Site Administrators will be responsible for this task. During the rebuilding process,
or after the new site goes ‘live’ to the public, the Site Admin may have granted
permission to others to take part in content contribution and/or editing.
This document covers the basic tasks needed by contributors if they wish to create an
Event or a News Item for their UofL site, via the Plone 4 Content Management
System. The step-by-step instructions are aimed at a non-technical user. Readers will
learn how to create and edit content for Events and News. They’ll practice these skills
using Plone’s TinyMCE visual editor. Next, they’ll go one step further and learn how to
add an image to the event & news story, by exploring folder creation and uploading
photos that are ADA compliant. As with the other ‘Basic’ Plone courses they’ll cover
saving, previewing, and publishing their work… all new processes when using Plone 4.
This documentation is written as part of Information Technology’s short
course program, which is accompanied by face-to-face instruction. (JLV)

Getting Started - Login
In order to add or modify content to your website you must first login. The login button
can usually be found in the top right hand corner of your page. If it is not there, the
theme you have installed may have it located elsewhere on the page.
When you are prompted to login, or if you manually click the login button, you will be
asked for your user ID and password. These are your ULink login credentials.

When you click login (or enter) you will be taken back to the page you were originally
on except there will be a Green Toolbar across the top of the page. This is your new
edit bar and is a sign that you are working in Plone 4 (& have edit permissions).
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Plone 4’s Green Toolbar

The Green Toolbar has several tabs and functions depending upon your context.
Some of the functions on the toolbar can include:


Contents: Lists the contents of the folder you are currently in. It’s also the root
of the folder where you will be able to make some changes to all contents.



View: View the default view of the current item



Edit: Opens the edit screen for the content item you are viewing. If you are
viewing the table of contents, this will let you edit the settings of the folder.



Rules: Automatically perform an action on items under certain conditions, such
as add a new item



Sharing: Grant and modify the user permissions for the item you are viewing



Preview: View your page, as the public would see it, before you publish it



Actions: Dropdown menu allows you to cut, copy, paste, delete, or rename the
current item. CAREFUL USING THE ACTIONS MENU! (See below)



Display: Modify the default view of the current folder



Add new: Choose items from the dropdown that you would like to add to the
current folder



State: Change the workflow state of the current item (internal, external, etc.)

The toolbar’s ‘Actions’ drop-down menu has a Delete function
that should NOT be used!
(Unless you want to trash what you’re working on)
Choosing ‘Delete’ from the ‘Actions’ drop-down menu WILL DELETE
whatever you’re on, whether it’s a page, folder, etc.

Page

3

How-To: Create/Add an Event
Plone 4 allows you to notify your customers of upcoming events. UofL sites have a
built-in system for populating events, via the portlets (controlled by the Site Admin).
The Events portlet automatically gathers and lists events from the entire site, not just
from a specific folder.
NOTE: The Home page of your departmental site MAY HAVE an ‘Events’ folder
already created for you. For class instruction (in the Plone 4 training sandbox) we
can’t access the Training Home page, so we will first create an Events folder, within
the folder with our name. Creating a folder is suggested for organization of site events.
1.

Navigate to your site’s home page (for class: the folder with your name)

2.

Choose the bullet point (below) which pertains to your site:

 If working from the home page: Click on the Events folder in the left sidebar
and Proceed to Step 3

 If working from your class folder OR if you don’t see an Events folder:
Create an Events folder by following these steps, then proceed to step 3…
A. Create a new folder… Add new > Folder

B. Type: Events in the Title field or give the folder any name Ex: Training
Schedule, Upcoming Symposiums, Faculty & Staff Workshops, etc.
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C. Click Save

3.

From the Green Toolbar, with the View tab chosen, click Add new > Event

4.

NOTE: The only fields that are required are those with the red square
These include: Title, Event Starts, & Event Ends.
However, we will explore other options by filling in the additional fields.
List of the available fields:
•
•
•
•
•
•
•
•
•
•
•
•

5.

Title - REQUIRED
Description
Event location
Event Starts (Start date and time) - REQUIRED
Event Ends (End date and time) - REQUIRED
Event body text (visual editor panel)
Attendees
Event URL
Contact Name
Contact Email
Contact Phone
Change note

Click in the Title field and type: UofL Alumni Bake Sale
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6.

The Description field includes a short summary of the event and is used in
item listings and by search engines for matching results.
In the Description field type: UofL fundraiser guest Rachael Ray presents
baking demos, cooking tips and tricks.

7.

Click in the Event Location field and type: Grass Quad between Ekstrom &
Humanities (Option-To make it shorter, just type: Grassy Quad)

8.

The Event Starts selections are required. The first 3 drop-down menus are for
the date. The next 3 drop-down menus are for the start time.
Pull down the drop-down menus and choose the Year, Month, and Day, then
choose the Hour, Minute, and AM/PM
*For class enter: 2015 / October / 2 - then enter 10 : 00 : AM

NOTE: For reference you can click on the small Calendar Icon to the right of
the ‘Day’ to see the corresponding days of the week (October 2nd is on a
Friday) or you can click on the calendar and choose the date from there.
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Date is Displayed

9.

The Event Ends selections are also required. The first 3 drop-down menus are
for the date. The next 3 drop-down menus are for the start time.
Pull down the drop-down menus and choose the Year, Month, and Day, then
choose the Hour, Minute, and AM/PM
*For class enter: 2015 / October / 2 - then enter 5 : 00 : PM

The same rule applies to using the Calendar Icon, as above.
10.

The visual editor’s Event Body Text can be used to add a short article or
paragraph (promotional ad) explaining the event.
Click in the Event Body Text and type: Television star and cookbook author,
Rachael Ray, will appear live at this year’s UofL Alumni Bake Sale
Make this a Subheading, then press enter

11.

For the promotional ad or short article that tells about the event, type:
Rachael will demonstrate how baking a cake is as easy as 1-2-3-4, as well
as present timesaving cooking tips and tricks…. (etc.)
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12.

The Attendees field is where you would put the special guest, keynote speaker,
or invitation note for the event. Just type the person’s name(s) in this field OR
you can also add a note. Ex: All Dental School faculty and staff are invited to
attend OR… This event is open to the public.
Click in the Attendees field and type: Rachael Ray, press enter, then type:
Dr. James R. Ramsey

13.

The Event URL is where you can enter a web address that includes more
information about the event, guest, speaker, etc. For example: This could be a
link to a page or news story within your department’s site or an external link to
the guest’s website or bio. Make sure you add http:// for external links (If it is
not present when you paste the URL).
 The link you add here will direct the visitor to the site when they click on:

 If you do not add a URL in this field: “More information about this event…”
will not show up on the published event page.
 If you don’t like this text you can always add a link in the Body.
Copy the complete URL from the preferred web page
Click in the Event URL field and Paste the URL from the web page, or type the
URL

NOTE: The URL that was added here points specifically to Rachael Ray’s
article where they promote how ‘baking a cake is as easy as 1,2,3,4’…
However, you can point to the guest’s homepage, if desired.
http://www.rachaelray.com/article.php?article_id=206&section=home
Page
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The Event URL direct visitors, via the ‘More information’ link, to a page explaining
the event, the guest’s website, or a keynote speaker’s bio. It’s up to you!

14.

Contact Info: Only the name and phone are visible to the site visitor. When
they click on the contact name, it launches their default email app and the email
address appears automatically in the ‘To’ field.
Click in the Contact Name, Contact E-mail, and Contact Phone fields and
enter the information

15.

The editor can add notes in the Change note field and use those later as a
reference for the ‘History’ of the event. If you leave this field blank… The first
initial creation of the event will show up in the History as the ‘Initial revision’ and
other revisions will show up as ‘Edited’. Therefore, the Change notes help the
editor keep track of the edits in case they later want to view, compare, or revert
to a previous revision. (To access the event history: See the upcoming illustration)

16.

Scroll to the bottom of the page and click Save

Page

9

VERY IMPORTANT:
The event includes a Visual Editor and the ONLY WAY YOU SHOULD EXIT
the event (when you click on Edit) is to click Save or Cancel at the bottom of
the page. Exiting the event visual editor by clicking on the back arrow button of
the browser or by clicking on a link will LOCK the page.
Others can unlock the event BUT… if both you and another editor are
modifying at the same time it will only save the changes from the last person
that saves it, meaning none of the other person’s edits will be included!

To see the change notes, click History under the page title.
From there you can ‘View’, ‘Compare’ and ‘Revert’ to a previous revision.
IF YOU DELETE A PAGE, FOLDER, ETC. THE HISTORY IS ALSO DELETED…
JUST LIKE THAT CONTENT NEVER EXISTED, SO YOU CANNOT RETRIEVE IT

After you Save the page, it defaults to the View tab & verifies the changes were saved

About: Text Formatting
Plone offers a platform-independent WYSIWYG (‘What You See Is What You Get’)
HTML editor, called TinyMCE (Tiny Moxiecode Content Editor), to add and edit text.
This editing interface helps non-technical contributors format the text of a web page,
insert images, links, and create lists. Text formatting includes headings, bold and
italics, and styles.
There are NO CHOICES OF FONT STYLES OR COLORS, as your
departmental site theme (template) predetermines this. This keeps the
look and feel of your site consistent. Site admins, or editors that edit in
HTML, can make some alterations, but may be subject to approval by the
Office of Communications and Marketing.
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Previewing and Publishing
Plone 4’s Preview button allows you to view your site when editing, as the public
would see it, before you publish it. The tab is located in the Green Toolbar of pages
and folders.


When using the visual editor, the TinyMCE interface looks the same for all
departments. You should preview your edits before you publish, so you can
see how the page will look with your department’s theme (template) applied.
You do not have a choice of fonts, so previewing is best way to see how the
edited page will display using the site’s theme.



It’s simple… Before you publish, click the Preview tab.



When in ‘Preview’ mode, click the browser back arrow (previous page) to
continue editing or to publish.

With Plone 4 you have to PUBLISH ALL pages,
folders, events, news items, etc. for them to be
visible!!


When creating new pages and folders, they automatically default to an ‘Internal
draft’ state so you can publish later.
The page is NOT VISIBLE to the public when it is an Internal draft



Publish externally will make the page visible to the public. When you’re ready
to publish, pull down the State drop-down menu and choose Publish
externally. The State will now read: Externally visible.
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Publish internally / Internally published means the site visitor has to log in to
see the page. Anybody that is in the Active Directory system (all faculty, staff,
students, and sponsored accounts) would be able to log in and see the page.



Publish restricted / Internally restricted also means that the site visitor has
to log in to see the page. The difference is that you restrict who can see the
page via the Sharing tab. Restricted requires them to have ‘Can view’
permission to access the content.



To give restricted users permission OR to give edit permissions to pages:
1. Click on the Sharing tab.
2. For ‘Restricted’ users: Break the inheritance from higher levels by
unchecking the checkbox. For other pages you can keep the
inheritance.
3. Add the specific users one at a time and choose their permission levels
by checking the boxes next to the choices. You must at least choose
‘Can View’. Other levels include ‘Can Add’, ‘Can Edit’, and ‘Can
Review’.
4. Choose Save each time you add a name.
Hint: Searching via userID (instead of lastname,firstname) will narrow
the results to that specific person, therefore speeding up the process.



If you publish the page (i.e. Externally visible, Internally published) and later
want to manually pull the page and take it offline, choose Retract from the
‘State’ dropdown menu. The State will change back to ‘Internal draft’ and will
not be visible to the public, but will still be available under the ‘Contents’ tab.

Once you Retract, the State changes to Internal draft

If you Delete a page (folder, etc.) it will permanently delete and
WILL NOT be recoverable.
If you just Retract, it will be remain stored under the Contents tab.
To Publish Several Pages at Once: (Step-by-step illustrations pages 20-21)
1. Navigate to the Home Folder or the folder that contains the contents
2. Click the Contents tab from the Green Toolbar
Page
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3.
4.
5.
6.

7.

The far right column will show you the ‘State’, making Internal draft
contents easy to spot
Select the checkboxes of the contents you want to publish
Click the Change State button at the bottom of the contents
The ‘Publishing process’ page gives you several options, like
choosing a publishing date or an expiration date. An item is not
publicly searchable before its publishing date. You can also bypass
the publishing date and expiration date, meaning the page will publish
immediately when you click Save. It will never expire until you Retract
it manually.
Click Save at the bottom

Editing Content
GOOD NEWS!

Effective Oct. 28, 2013 ALL editors, as well as Site
Admins, can Edit content without Retracting.
Editing Directly vs. Check-out a Working Copy
Editing directly or choosing to Check-out the content is a matter of preference
and most importantly confidence in your editing skills.

Editing Directly


If the content is ALREADY PUBLISHED, small changes can be edited by
choosing the Edit tab first (editing directly), therefore bypassing the ‘Check-out’
process.



When directly editing a page the changed page replaces the live page
immediately when you click Save.



Editing directly, without checking out first, doesn’t offer you a ‘safety net’ of
being able to Preview your fully changed page and make sure it’s correct,
without errors, before replacing the live page. If errors exist they will
immediately be visible to the public.



As opposed to Retracting… While editing directly (without checking out) the
public can view the current version. This is technically not the last saved
version because you can revert to an older version via the ‘History’.

Editing via a Working Copy


After content is ALREADY PUBLISHED, if you need to make more than a small
change, it is recommended that all Editors (including Site Admins) should
Check-out the page and make edits in a ‘Working Copy’. (especially for adding
images).
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Editing via the Check-out/Check-in cycle is a MUCH SAFER option for editing
pages requiring more than just a quick edit. There’s no danger of messing up
the live page if a mistake is made during the editing process. Again, direct
editing makes the page live when you click Save, where checking out a
Working Copy allows you to Preview the changes after you click Save, assuring
that no spelling, grammar, or placement errors are ever visible. You can Edit,
Save, then Preview several times. The page will not go live until you Check-in
the content.



As opposed to Retracting… Working copy also makes it possible to keep the
current published page (folder, event, news item, etc.) visible on the web while
you are making revisions. When done working, the new modified page can be
checked-in and will replace the current page. This works well for a page that
you update often, and keeps the history of the old version, just in case.



To do this, you ‘Check Out’ a version of the currently published page, which
creates a ‘Working Copy’. You then make your edits and ‘Check In’ the
working copy. Plone replaces the original with the new, in the exact same
location and URL. The new page is now live. The old version’s history is
recorded.

 From the Actions Drop-down menu choose Check out

 Two info messages appear letting you know you are in a ‘working copy’ and
that Check-out was created, while the ‘State’ changes to Internal draft
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 Edit and Save your local copy of the published page. During this time, the
original page is LOCKED. No one else can edit the published version of that
page while you have a working copy checked out. This prevents other changes
from being made to the published version while you edit your copy.
 A message lets you know that your edits were saved
 After you’re satisfied with the Preview, from the Actions menu, choose Check
in

 You are prompted to enter a Check-in message, then choose Check in
 Your updated page will now be live and replace the published version and
become the new published copy
 NOTE: If you start making edits and decide not to save any of the changes,
navigate to the working copy and from the Actions menu choose Cancel
check-out. You will be prompted to confirm that you want to Cancel checkout.

How-To: Choose ‘When’ to Publish & Pull an Event
Often times for an event, you may want to wait and publish it on a certain date, as well
as assuring that the event expires, when desired. When creating an event with
specified dates, leave it in Internal draft state, and publishing will occur, as scheduled.
1.

Navigate to the Event – UofL Alumni Bake Sale

2.

Click the Edit tab

3.

Click Dates from the Gray Bar – (w/blue text that turns green when hovering)
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4.

Use the drop-down menus from the Publishing Date section to choose a date
and time you want the event to be published. If no date is selected the event
will be published immediately.
(As earlier… The first 3 drop-down menus are for the date. The next 3 dropdown menus are for the start time.)
Pull down the drop-down menus and choose the Year, Month, and Day, then
choose the Hour, Minute, and AM/PM
*For class enter: 2015 / August / 3 - then enter 8 : 00 : AM

NOTE: For reference you can click on the small Calendar Icon to the right of
the ‘Day’ to see the corresponding days of the week (August 3rd is on a
Monday) or you can click on the calendar and choose the date from there.

Date is Displayed

5.

In the Expiration Date section choose a date and time you want the event to
expire (To be retracted, and no longer be visible online). If no date is chosen it
will never expire.
Pull down the drop-down menus and choose the Year, Month, and Day, then
choose the Hour, Minute, and AM/PM
*For class enter: 2015 / October / 2 - then enter 5 : 00 : PM

6.

Enter the changes you made.
Don’t forget to publish the
Events Folder!

7.

Click Save
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About: Adding an Image to an Event – (Optional)
With Plone 4 you can ‘spice up’ your event by adding an image on the event page.
For example: You may want to include the organizing department or company’s logo,
a small photo of the guest/keynote speaker, or a different image that correlates with
the event. Since this is a bake sale, a cupcake will be added.
FIRST, it is recommended that you create a folder to store all the site’s uploaded
images, and then add the image to the event. It is also recommended that you hide
the ‘Images Folder’ from navigation so the public does not see all the photos uploaded
to your site, when you only want to display relevant ones.
The next 4 sections show how to complete these tasks and ensure that the image is
compliant with the Americans with Disabilities Act.

How-To: Create a Folder and Upload Images (w/ADA Compliance)
Again, it is recommended that you create folders to store files and images. You can
create as many folders as you like, according to how you want to organize your
content. In this case we will create one folder to hold our images, but you can create
multiples, as needed. Make sure you choose ‘Folder’ and not ‘Form Folder’ (used to
create forms).
1.

Navigate to your folder (with your name)

2.

Create a new folder… Add new > Folder

3.

Type: Images Folder in the Title field

4.

Click Save
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5.

From the Images Folder, Click Add new > Image

6.

Browse for your photo by clicking on Browse or Choose File at the bottom of
the ‘Add Image’ page, then search for the image

7.

Once your image is chosen, give it a short name in the Title field

8.

In the Description field, enter a description of the photo that will serve as ‘Alt
Text’ for ADA Compliance. This is the text that screen reader software will
read, and gives details of the image to the person with a visual impairment.
NOTE:
 It is NOT mandatory that you add a description when uploading images to
the folder, IF YOU HIDE it from navigation.


9.

It IS mandatory (the law) that you tag the photo with a description when
adding the image to a page. Therefore, you can wait to add the ‘Alt Text’ at
the time of insertion, if desired; as long as the folder that stores the full list of
pictures is not visible.

Click Save
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10.

You will see the picture has uploaded into the Images Folder

11.

Don’t forget to always Publish the Images Folder (or to keep the images
folder published) so your photos will show up on your page. You may want to
hide the folder from the navigation pane, so the public doesn’t see the unused
photos stored in the Images Folder. (See the next topic)
Keep in mind that if a photo has been added to a page and is not visible, you
may not have the Images Folder published. The fix is to go to the Images
Folder and publish it. The photo should show up on the page then

How-To: Exclude Folders from the Navigation Pane
You may want to Exclude (hide) the Images Folder from navigation. This way, the
only photos that are accessible are the images you add to pages. You can also hide
any folder this way (e.g. your pdf folder).
1.

Navigate to your Images Folder
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2.

Click the Edit tab from the Green Toolbar

3.

Click Settings from the Gray Bar – (w/blue text that turns green when
hovering)

4.

Click the checkbox beside Exclude from navigation to activate this feature

5.

Click Save

6.

Navigate elsewhere & the Images Folder will disappear from the sidebar

How-To: Access Hidden Folders & Contents for Publishing
Once you hide a folder you need access to the folder to publish it. You also may
decide you want to publish several contents at once, or take a look at what is
published and what is in internal draft state.
1.

Navigate to the folder with your name

2.

Click the Contents tab from the Green Toolbar

The Contents tab gives you a great overall picture of the state of your
entire website and you can easily see what has not been published yet.
3.

Select the checkbox beside the Images Folder (in the list) or select several
checkboxes beside all of the contents to publish them all at one time.
The example shown below was for test purposes, as you can see that
everything is still in the Internal draft State.
Page
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4.

Choose Change State from the bottom, below the contents list

State is
indicated in
the far right
column

5.

Notice that after you click ‘Change State’ that there are also options to ‘Publish’
or ‘Expire’ on a certain date, if desired.
o If the Publishing Date is left blank, it will be published immediately
o If the Expiration Date is left blank, it will never expire (it will remain
visible)
o Since you would want to publish the Images Folder immediately, and
would not want it to expire at a certain date, you can leave the 2 above
choices alone

6.

At the bottom of the Publishing Process page, choose to Publish the folder.
(See page 11-12 for publishing option descriptions)

6.

Click Save
Page

21

How-To: Add an Image to an Event
With Plone 4 you can ‘spice up’ your event by adding an image on the event page.
For example: The organizing department or company’s logo, clip art, or a thumbnail
photo.
1.

Navigate to the Event – UofL Alumni Bake Sale

2.

Click the Edit tab. However… For replacing or adding images to already
published pages it is recommended that you use the Check out/in method so
you can Preview before it goes live.

3.

Click in the Event body text where you want the image to appear
(For class: place the cursor to the left of ‘Television star and cookbook author…’

4.

Click the Insert/edit Image (tree) icon

5.

Under the ‘Image list’ click Up one level

6.

Click Images Folder from the Image list

7.

Click the radio button beside the image (i.e. Cupcake)

8.

The details of the Image appear, including an image preview and description.
The description field is Alt Text (required for ADA compliance). If you
included a description when you uploaded the photo, it is listed in the field.
You can also change the description, if needed.

and a dialog box opens
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You cannot leave the Image description field blank, when you are adding the
photo to the page or event, and be in compliance with the Americans with
Disabilities Act.

9.

Choose the Alignment (Choose Left to appear to the left of the text)

10.

Choose the Dimensions (Image size)

11.

Scroll to the bottom of the dialog box and click Insert to go back to the editor

To change the image size or alignment: From the editor > select the image >
choose the Image ‘tree’ icon > make adjustments > click Update
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12.

If satisfied with the results showing in the editor… Save the Event!!
Don’t forget to Save the Event

13.

Preview the page to see what it will look like when your theme is applied

The ‘UofL Alumni Bake Sale’ event in Preview mode with the Organizational Theme

Event Folder Display
If you choose you can display your events on a Calendar. You must do this at the
folder level.
1.

Navigate to the Events Folder and open it

2.

Make sure the View tab is chosen
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3.

From the Green Toolbar click Display and choose Solgema Fullcalendar from
the drop-down menu

4.

The display will immediately change to the Calendar view

This Events Folder, Training Schedule, was set to display as Solgema FullCalendar view.
The title of the event will be shown in full and the calendar will expand to compensate.

How-To: Create/Add a News Item
Like events, UofL Plone 4 sites have a built-in system for populating news items, via
the portlets (controlled by the Site Admin). The News portlet automatically gathers
and lists news items from the entire site, not just from a specific folder.
NOTE: The Home page of your departmental site MAY HAVE a ‘News’ folder already
created for you. For class instruction (in the Plone 4 training sandbox) we can’t
access the Training Home page, so we will first create a News Item folder, within the
folder with our name. Creating a folder is suggested for the organization of site news.
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1.

Navigate to your site’s home page (for class: the folder with your name)

2.

Choose the bullet point (below) which pertains to your site:

 If working from the home page: Click on the News folder in the left sidebar
and Proceed to Step 3

 If working from your class folder OR if you don’t see a News folder: Create a
News item folder by following these steps, then proceed to step 3…
A. Create a new folder… Add new > Folder

B. Type: Events in the Title field

C. Click Save
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3.

From the Green Toolbar, with the View tab chosen, click Add new > News
Item

4.

Click in the Title field and type: UofL Alumni Bake Sale a Sweet Success!

5.

In the Summary field type: University of Louisville invites celebrity
Rachael Ray to cook on campus (this will be used by search providers)

6.

In the Body Text type: Rachael Ray & Dr. Ramsey ‘cook up’ some laughs
at this year’s UofL Alumni Bake Sale
Before you leave this line, choose Heading from the Styles menu
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7.

OPTIONAL: If you wish to include a byline with the author and date... Insert the
text on the next line.

Byline
8.

On the next line below the byline, begin typing your news story

9.

When finished with the story, go back up to the byline and Select/highlight the
author and date, and then from the Styles menu choose Discreet

10.

It’s a good practice to Save the news item, occasionally, so you don’t lose your
work.
Go ahead and Save now

11.

Click on the Edit tab to open the editor back up for further additions

12.

In the Image section, choose an image from your computer that will appear in
the news listing (Browse or Choose File). A small ‘sensible size’ will be preselected for you. Include a caption to make sure it is ADA compliant. When
adding a photo this way, the caption is the same as Alt Text (aka: Description).
Therefore the caption WILL SHOW under the photo & is also ADA compliant.
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Notice that this image was uploaded from your computer straight to the news
item page. It is not stored in the Images Folder, as in the past.

13.

OPTIONAL: In the Change note field, indicate the changes made since your
last save

14.

Click Save at the bottom

15.

Preview the news item to see what it will look like with your theme.
DO NOT TRUST THE ‘VIEW’ TAB (after you save) because everything could
be shifted. The small image is a perfect example. It shows up on the right from
the ‘View’ tab in the green toolbar, and the caption appears at the lower 4 th of
the photo. The image and caption are actually aligned vertically under the title
when in Preview

The News Item in Preview mode with the Organizational Theme Applied
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How-To: Add an Additional Photo to a News Item (optional)
I like to add a large photo within the body of the story to catch, and keep, the reader’s
attention. As seen above, the image I attached to the news item appeared at the top,
with the caption under the photo. The predetermined sizing for this image is small, but
if a visitor clicks on the photo, the original size will be displayed.
In the example below I have another photo I wish to include within the body of the
news story, and I want it to be larger than the previous image.

1. Navigate to the *Images folder and upload a photo & include a description
to make the photo ADA compliant
*If you have not created an Images folder, uploaded photos, or made an image
accessible (ADA compliant), follow the instructions on pages 17-19. Pages 1921 show how to hide the Images folder from navigation, and also includes
important notes about publishing folders (e.g. News & Events folders).

2. Navigate to the News Item and click Edit from the green toolbar. Since the
page has not been published yet you can edit directly. Otherwise, if published,
you would need to add an additional photo via the Check-out/in method so
you can preview the results before going live.

3. Place your cursor within the body text, where you want the photo to appear

Cursor

4. Click the Insert/edit Image (tree) icon

and a dialog box opens

5. Under the ‘Image list’ click Up one level
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6. Click Images Folder from the Image list

7. Click the radio button beside the image (i.e. Rachael & Ramsey)

8. The details of the Image appear, including an image preview and description.
The description field is Alt Text (required for ADA compliance). If you
included a description when you uploaded the photo, it is listed in the field.
You can also change the description, if needed.

You cannot leave the Image description field blank, when you are adding the
photo to the page, event, news item, etc. and be in compliance with the
Americans with Disabilities Act for accessibility.

The description for this
photo was:
Rachael Ray & Dr.
Ramsey sharing
laughter & cooking tips
during the UofL Alumni
Bake Sale
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9. Choose the Alignment (Choose Left to appear to the left of the text)

10. Choose the Dimensions (Image size)

11. Scroll to the bottom of the dialog box and click Insert to go back to the visual
editor

To change the image size or alignment: From the editor > select the image >
choose the Image ‘tree’ icon > make adjustments > click Update

12. If satisfied with the results showing in the editor… Save the News Item!!
Don’t forget to Save the News Item
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13. The View tab will NOT align the images nor the story as they will be displayed

Don’t rely on the ‘View’ tab to display the images and news story correctly

14. Preview the page to see what it will look like when your theme is applied

The Completed News Item in Preview mode with the Organizational Theme Applied

15. Publish the news item when finished (make sure news folder is published also)
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ALWAYS log out of Plone when you are finished!
If you log out of your AD computer this will log you out of Plone, as well.
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